Каталог тестов
Главная » Тесты » Вопросы тестов онлайн » Тесты с ответами

Тест по информатике

1. Найдите решение уравнения  16 Кб= 32*X бит

A) 4

B) 2

C) 2048

D) 4096

E) 4000

2.  Сколько различных чисел можно закодировать с помощью 10 бит?

A) 100

B) 1024

C) 9

D)10

E) 27

3.  Сколько единиц в записи десятичного числа 45 в двоичной системе счисления?

A) 2

B) 4

C) 3

D) 8

E) 1

4. На какую цифру заканчивается число в десятичной системе счисления, если в двоичной системе счисления оно имеет вид 11101?

A) 2

B) 3

C) 4

D) 9

E) 1

5. При скольки целых значениях x будет истинным логическое выражение ((x>34)Ú (x>32))× (x<34)?

A) 3

B) 4

C) 5

D) 1

E) 0

6.   В базе данных с полями «Страна изготовитель» и «Товар» содержится 60 записей. Запросу «Страна изготовитель=Тайвань» удовлетворяет 10 записей. Запросу «(Товар=модем) или (Страна изготовитель=Тайвань)» удовлетворяет 15 записей. Сколько записей удовлетворяет запросу «(Товар¹модем) и (Страна изготовитель¹Тайвань)»?

A) 5

B) 15

C) 35

D) 40

E) 45

7. Известно, что некоторое целое число занимает в памяти  один байт и имеет ровно один ненулевой бит, причем этот бит имеет четный номер. Сколько различных чисел удовлетворяет данному условию?

A) 1

B) 2

C) 4

D) 16

E) 256

8. Полный путь к файлу test.txt в операционной системе Windows XP имеет вид “c:\a\b\d\e\test.txt”. На каком диске размещается файл test.txt?

A) a

B) b

C) c:

D) d

E) e

9. Постройте запрос поиска по базе данных с полями «Товар», «Страна Изготовитель» противоположный данному:  (Товар¹модем) или (Страна Изготовитель=Тайвань)

A) (Товар=модем) и (Страна Изготовитель¹Тайвань)                 B) (Товар¹модем) или (Страна Изготовитель¹Тайвань)                

C) (Товар¹модем) и (Страна Изготовитель¹Тайвань)                D) (Товар¹модем) или (Страна Изготовитель>Тайвань)                

E) (Товар>модем) и (Страна Изготовитель>Тайвань)

10. Чему будет равно значение переменной a после выполнения цепочки операций присваивания: a:=2; b:=3; b:=b-a; c:=(a+b-1)*2; d:=c+a-b; a:=a*b*c+d;

A) 54

B) 7

C) 0

D) 18

E) 13

11. Переведите десятичное число 1.3 в семиричную систему счисления.

A) 1.(6024)

B) 1.(2406)

C) 1.(2046)

D) 1.(42)

E) 1.(246)

12. Упростите логическое выражение

A) 0

B) 1

C) A

D)

E)

13. Что будет отображено на экране монитора в результате выполнения фрагмента алгоритма

a:=25; s:=0;

нц. пока a>0

   a:=div(a,3)

   s:=s+1 

кц.

вывод s

A) 4

B) 5

C) 6

D) 3

E) 2

14. Что будет выведено на экран монитора в результате выполнения фрагмента алгоритма

s:=0;

нц для i от 1 до 10

  если mod(i,2)=1 или mod(i,3)=0

   s:=s+1;

  все

кц

вывод s;

A) 3

B) 4

C) 5

D) 6

E) 7

 

15. Что будет выведено на экран монитора в результате выполнения фрагмента алгоритма

s:=0;

нц для i от 1 до 999

  если mod(i,10)=div(i,10)

   s:=s+1;

  все

кц

вывод s;

A) 9

B) 10

C) 8

D) 99

E) 89

16. Что будет выведено на экран монитора в результате выполнения фрагмента алгоритма

a:=1; s:=9;

нц дляот 1 до 10

            a:=a*(i+1)/i;

            s:=s*a/(i+1);

кц

Вывод s

A) 53

B) 27

C) 44

D) 54

E) 9

17. Чему равно значение в ячейке С3 электронной таблицы?

 

A

B

C

 

1

2

2

=A1+A2

 

2

2

=A1+B1

=А1+B3

 

3

2

=2*A2

=(С1+С2)/2

 

A) 3

B) 4

C) 5

D) 8

E) 1

                 
 

18. Что будет выведено на экран монитора в результате выполнения фрагмента алгоритма

s:=0;

нц для U от 0 до 9

      нц для V от 0 до 9

            если U*10+V=V*4+U

                 то s:=s+1;

            все

      кц

кц

вывод s;

A) 3

B) 10

C) 0

D) 4

E) 100

19. Что будет выведено на экран монитора в результате выполнения фрагмента алгоритма

s:=0;

нц для i от 1 до 5

      A[i]:=div(2*(i+1),i)-mod(i*2,3);

кц

s:=A[A[A[A[2]+2]+1]*2+1];

вывод s;

A) 0

B) 1

C) 2

D) 3

E) -1

20. Что будет выведено на экран монитора в результате выполнения фрагмента алгоритма

s:=0;   N:=3;

нц для i от 1 до N

     нц для j от 1 до N

          A[i,j]:=(i+j)*2-mod(i*j,2);

      кц

кц

нц для i от 1 до N

     нц для j от 1 до N

           A[i,j]:=mod((i+2*j)*mod(A[i,j],3)*A[mod(A[j,i],3)+1,mod(A[i,i],3)+1],3)

      кц

кц

нц для i от 1 до N

      если A[i,i]>0

             то  A[4-i,4-i]:=[N-i+1,i];

кц

нц для i от 1 до N

         s:=s+A[1,i]+ A[2,i];

кц

вывод s;

A) 0

B) 1

C) 2

D) 3

E) 4

Ответы к тесту

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

D

B

B

D

D

E

C

C

A

E

C

C

D

D

A

E

C

D

B

A

Категория: Тесты с ответами | Добавил: Ирина (15.10.2016)
Просмотров: 1008 | Рейтинг: 0.0/0
Всего комментариев: 0
avatar